Vulnerability · Published May 30, 2023 · Assigned by apache
CVE-2023-33234Apache Airflow CNCF Kubernetes Provider: KubernetesPodOperator RCE via connection configuration
High 7.2
In plain English
A high-severity injection in Apache Airflow CNCF Kubernetes Provider from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.5% (higher than 75% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Arbitrary code execution in Apache Airflow CNCF Kubernetes provider version 5.0.0 allows user to change xcom sidecar image and resources via Airflow connection. In order to exploit this weakness, a user would already need elevated permissions (Op or Admin) to change the connection object in this manner. Operators should upgrade to provider version 7.0.0 which has removed the vulnerability.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | apache-airflow-providers-cncf-kubernetes | 7.0.0 | GHSA-2rx4-9f5h-9gjf |
| PyPI | apache-airflow-providers-cncf-kubernetes | 7.0.0 | PYSEC-2026-1143 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Airflow CNCF Kubernetes Provider | 5.0.0 – through 6.1.0 |
Weakness: CWE-74 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
References
- https://lists.apache.org/thread/n1vpgl6h2qsdm52o9m2tx1oo86tl4gnq vendor-advisory