Vulnerability · Published May 27, 2023 · Assigned by GitHub_M
CVE-2023-32688Invalid push request payload crashes Parse Server
Medium 4.9
In plain English
A medium-severity improper input validation in parse-server-push-adapter from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)4.9Medium
Exploit odds (30 days)0.9%top 40.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
parse-server-push-adapter is the official Push Notification adapter for Parse Server. The Parse Server Push Adapter can crash Parse Server due to an invalid push notification payload. This issue has been patched in version 4.1.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | parse-server-push-adapter | 4.1.3 | GHSA-mxhg-rvwx-x993 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| parse-community | parse-server-push-adapter | < 4.1.3 |
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/parse-community/parse-server-push-adapter/security/advisories/GHSA-mxhg-rvwx-x993 x_refsource_CONFIRM
- https://github.com/parse-community/parse-server-push-adapter/pull/217 x_refsource_MISC
- https://github.com/parse-community/parse-server-push-adapter/releases/tag/4.1.3 x_refsource_MISC