Actively exploited · Published Jun 23, 2023 · Assigned by apple
CVE-2023-32439
High 8.8 Exploited
In plain English
A high-severity type confusion in iOS and iPadOS from Apple. Attackers are actively exploiting it in the wild (listed by CISA on June 23, 2023). The chance it is exploited in the next 30 days is estimated at 24.0% (higher than 98% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
CISA guidance
Apply updates per vendor instructions.
Federal agencies must remediate by Jul 14, 2023.
Official description
A type confusion issue was addressed with improved checks. This issue is fixed in iOS 16.5.1 and iPadOS 16.5.1, iOS 15.7.7 and iPadOS 15.7.7, macOS Ventura 13.4.1, Safari 16.5.1. Processing maliciously crafted web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | webkit2gtk3 | 2.38.5-1.el8_8.5.alma | ALSA-2023:4202 |
| AlmaLinux:9 | webkit2gtk3 | 2.38.5-1.el9_2.3 | ALSA-2023:4201 |
| AlmaLinux:8 | webkit2gtk3-devel | 2.38.5-1.el8_8.5.alma | ALSA-2023:4202 |
| AlmaLinux:9 | webkit2gtk3-devel | 2.38.5-1.el9_2.3 | ALSA-2023:4201 |
| AlmaLinux:8 | webkit2gtk3-jsc | 2.38.5-1.el8_8.5.alma | ALSA-2023:4202 |
| AlmaLinux:9 | webkit2gtk3-jsc | 2.38.5-1.el9_2.3 | ALSA-2023:4201 |
| AlmaLinux:8 | webkit2gtk3-jsc-devel | 2.38.5-1.el8_8.5.alma | ALSA-2023:4202 |
| AlmaLinux:9 | webkit2gtk3-jsc-devel | 2.38.5-1.el9_2.3 | ALSA-2023:4201 |
| Debian:12 | webkit2gtk | 2.40.3-2~deb12u1 | DEBIAN-CVE-2023-32439 |
| Debian:12 | webkit2gtk | 2.40.3-2~deb12u1 | DSA-5449-1 |
| Debian:13 | webkit2gtk | 2.40.3-1 | DEBIAN-CVE-2023-32439 |
| Debian:14 | webkit2gtk | 2.40.3-1 | DEBIAN-CVE-2023-32439 |
| Debian:12 | wpewebkit | no fix listed | DEBIAN-CVE-2023-32439 |
| Debian:13 | wpewebkit | 2.40.3-1 | DEBIAN-CVE-2023-32439 |
| Debian:14 | wpewebkit | 2.40.3-1 | DEBIAN-CVE-2023-32439 |
| Rocky Linux:8 | webkit2gtk3 | 0:2.38.5-1.el8_8.5 | RLSA-2023:4202 |
| Rocky Linux:9 | webkit2gtk3 | 0:2.38.5-1.el9_2.3 | RLSA-2023:4201 |
| Ubuntu:22.04:LTS | qtwebkit-opensource-src | no fix listed | UBUNTU-CVE-2023-32439 |
| Ubuntu:24.04:LTS | qtwebkit-opensource-src | no fix listed | UBUNTU-CVE-2023-32439 |
| Ubuntu:22.04:LTS | webkit2gtk | 2.40.4-0ubuntu0.22.04.1 | UBUNTU-CVE-2023-32439 |
| Ubuntu:22.04:LTS | webkit2gtk | 2.40.4-0ubuntu0.22.04.1 | USN-6264-1 |
| Ubuntu:22.04:LTS | wpewebkit | no fix listed | UBUNTU-CVE-2023-32439 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apple | iOS and iPadOS | unspecified – before 15.7 |
| Apple | Safari | unspecified – before 16.5 |
| Apple | iOS and iPadOS | unspecified – before 16.5 |
| Apple | macOS | unspecified – before 13.4 |
Weakness: CWE-843 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://support.apple.com/en-us/HT213811
- https://support.apple.com/en-us/HT213816
- https://support.apple.com/en-us/HT213814
- https://support.apple.com/en-us/HT213813
- https://support.apple.com/kb/HT213814
- https://support.apple.com/kb/HT213816
- https://security.gentoo.org/glsa/202401-04
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-32439 government-resource