Actively exploited · Published Jun 23, 2023 · Assigned by apple
CVE-2023-32435
High 8.8 Exploited
In plain English
A high-severity out-of-bounds write in iOS and iPadOS from Apple. Attackers are actively exploiting it in the wild (listed by CISA on June 23, 2023). The chance it is exploited in the next 30 days is estimated at 23.0% (higher than 98% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
CISA guidance
Apply updates per vendor instructions.
Federal agencies must remediate by Jul 14, 2023.
Official description
A memory corruption issue was addressed with improved state management. This issue is fixed in macOS Ventura 13.3, Safari 16.4, iOS 16.4 and iPadOS 16.4, iOS 15.7.7 and iPadOS 15.7.7. Processing web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited against versions of iOS released before iOS 15.7.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | webkit2gtk3 | 2.38.5-1.el8_8.5.alma | ALSA-2023:4202 |
| AlmaLinux:9 | webkit2gtk3 | 2.38.5-1.el9_2.3 | ALSA-2023:4201 |
| AlmaLinux:8 | webkit2gtk3-devel | 2.38.5-1.el8_8.5.alma | ALSA-2023:4202 |
| AlmaLinux:9 | webkit2gtk3-devel | 2.38.5-1.el9_2.3 | ALSA-2023:4201 |
| AlmaLinux:8 | webkit2gtk3-jsc | 2.38.5-1.el8_8.5.alma | ALSA-2023:4202 |
| AlmaLinux:9 | webkit2gtk3-jsc | 2.38.5-1.el9_2.3 | ALSA-2023:4201 |
| AlmaLinux:8 | webkit2gtk3-jsc-devel | 2.38.5-1.el8_8.5.alma | ALSA-2023:4202 |
| AlmaLinux:9 | webkit2gtk3-jsc-devel | 2.38.5-1.el9_2.3 | ALSA-2023:4201 |
| Debian:12 | webkit2gtk | 2.40.0-1 | DEBIAN-CVE-2023-32435 |
| Debian:13 | webkit2gtk | 2.40.0-1 | DEBIAN-CVE-2023-32435 |
| Debian:14 | webkit2gtk | 2.40.0-1 | DEBIAN-CVE-2023-32435 |
| Debian:12 | wpewebkit | no fix listed | DEBIAN-CVE-2023-32435 |
| Debian:13 | wpewebkit | 2.40.2-2 | DEBIAN-CVE-2023-32435 |
| Debian:14 | wpewebkit | 2.40.2-2 | DEBIAN-CVE-2023-32435 |
| Rocky Linux:8 | webkit2gtk3 | 0:2.38.5-1.el8_8.5 | RLSA-2023:4202 |
| Rocky Linux:9 | webkit2gtk3 | 0:2.38.5-1.el9_2.3 | RLSA-2023:4201 |
| Ubuntu:22.04:LTS | qtwebkit-opensource-src | no fix listed | UBUNTU-CVE-2023-32435 |
| Ubuntu:24.04:LTS | qtwebkit-opensource-src | no fix listed | UBUNTU-CVE-2023-32435 |
| Ubuntu:22.04:LTS | webkit2gtk | 2.40.4-0ubuntu0.22.04.1 | UBUNTU-CVE-2023-32435 |
| Ubuntu:22.04:LTS | webkit2gtk | 2.40.4-0ubuntu0.22.04.1 | USN-6264-1 |
| Ubuntu:22.04:LTS | wpewebkit | no fix listed | UBUNTU-CVE-2023-32435 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apple | macOS | unspecified – before 13.3 |
| Apple | iOS and iPadOS | unspecified – before 15.7 |
| Apple | Safari | unspecified – before 16.4 |
| Apple | iOS and iPadOS | unspecified – before 16.4 |
Weakness: CWE-787 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H