Vulnerability · Published May 26, 2023 · Assigned by GitHub_M
CVE-2023-32325Cross-site scripting in PostHog-js
Medium 5.4
In plain English
A medium-severity cross-site scripting in posthog-js from PostHog. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.4%top 62.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
PostHog-js is a library to interface with the PostHog analytics tool. Versions prior to 1.57.2 have the potential for cross-site scripting. Problem has been patched in 1.57.2. Users are advised to upgrade. Users unable to upgrade should ensure that their Content Security Policy is in place.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | posthog-js | 1.57.2 | GHSA-8775-5hwv-wr6v |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| PostHog | posthog-js | < 1.57.2 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N