Actively exploited · Published May 26, 2023 · Assigned by GitHub_M
CVE-2023-32315Openfire administration console authentication bypass
High 8.6 Exploited
In plain English
A high-severity path traversal in Openfire from igniterealtime. Attackers are actively exploiting it in the wild (listed by CISA on August 24, 2023). The chance it is exploited in the next 30 days is estimated at 100.0% (higher than 99.9% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.
CISA guidance
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Federal agencies must remediate by Sep 14, 2023.
Official description
Openfire is an XMPP server licensed under the Open Source Apache License. Openfire's administrative console, a web-based application, was found to be vulnerable to a path traversal attack via the setup environment. This permitted an unauthenticated user to use the unauthenticated Openfire Setup Environment in an already configured Openfire environment to access restricted pages in the Openfire Admin Console reserved for administrative users. This vulnerability affects all versions of Openfire that have been released since April 2015, starting with version 3.10.0. The problem has been patched in Openfire release 4.7.5 and 4.6.8, and further improvements will be included in the yet-to-be released first version on the 4.8 branch (which is expected to be version 4.8.0). Users are advised to upgrade. If an Openfire upgrade isn’t available for a specific release, or isn’t quickly actionable, users may see the linked github advisory (GHSA-gw42-f939-fhvm) for mitigation advice.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.20 | openfire | 4.7.5-r0 | ALPINE-CVE-2023-32315 |
| Maven | org.igniterealtime.openfire:xmppserver | 4.6.8 | GHSA-gw42-f939-fhvm |
| Maven | org.igniterealtime.openfire:xmppserver | 4.7.5 | GHSA-gw42-f939-fhvm |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| igniterealtime | Openfire | >= 3.10.0, < 4.6.8>= 4.7.0, < 4.7.5 |
Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
References
- https://github.com/igniterealtime/Openfire/security/advisories/GHSA-gw42-f939-fhvm x_refsource_CONFIRM
- http://packetstormsecurity.com/files/173607/Openfire-Authentication-Bypass-Remote-Code-Execution.html
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-32315 government-resource