Vulnerability · Published May 12, 2023 · Assigned by GitHub_M
CVE-2023-32305aiven-extras PostgreSQL Privilege Escalation Through Overloaded Search Path
High 8.8
In plain English
A high-severity improper input validation in aiven-extras from aiven. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities).
Official description
aiven-extras is a PostgreSQL extension. Versions prior to 1.1.9 contain a privilege escalation vulnerability, allowing elevation to superuser inside PostgreSQL databases that use the aiven-extras package. The vulnerability leverages missing schema qualifiers on privileged functions called by the aiven-extras extension. A low privileged user can create objects that collide with existing function names, which will then be executed instead. Exploiting this vulnerability could allow a low privileged user to acquire `superuser` privileges, which would allow full, unrestricted access to all data and database functions. And could lead to arbitrary code execution or data access on the underlying host as the `postgres` user. The issue has been patched as of version 1.1.9.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| aiven | aiven-extras | < 1.1.9 |
Weakness: CWE-20, CWE-1321 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H