Vulnerability · Published May 11, 2023 · Assigned by GitHub_M
CVE-2023-32059Vyper vulnerable to incorrect ordering of arguments for kwargs passed to internal calls
High 7.5
In plain English
A high-severity security flaw in vyper from vyperlang. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Vyper is a Pythonic smart contract language for the Ethereum virtual machine. Prior to version 0.3.8, internal calls with default arguments are compiled incorrectly. Depending on the number of arguments provided in the call, the defaults are added not right-to-left, but left-to-right. If the types are incompatible, typechecking is bypassed. The ability to pass kwargs to internal functions is an undocumented feature that is not well known about. The issue is patched in version 0.3.8.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | vyper | 0.3.8 | GHSA-ph9x-4vc9-m39g |
| PyPI | vyper | 0.3.8 | PYSEC-2023-79 |
Affected products (as reported)
Weakness: CWE-683 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N