Vulnerability · Published May 9, 2023 · Assigned by GitHub_M

CVE-2023-31144Craft CMS vulnerable to cross site scripting in RSS feed widget

Medium 6.1

In plain English

A medium-severity cross-site scripting in cms from craftcms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.4%top 64.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Craft CMS is a content management system. Starting in version 3.0.0 and prior to versions 3.8.4 and 4.4.4, a malformed title in the feed widget can deliver a cross-site scripting payload. This issue is fixed in version 3.8.4 and 4.4.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcraftcms/cms3.8.4GHSA-j4mx-98hw-6rv6
Packagistcraftcms/cms4.4.4GHSA-j4mx-98hw-6rv6

Affected products (as reported)

VendorProductVersions
craftcms cms >= 3.0.0, < 3.8.4>= 4.0.0, < 4.4.4

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References