Vulnerability · Published May 22, 2023 · Assigned by apache
CVE-2023-31065Apache InLong: Insufficient Session Expiration in InLong
Critical 9.1
In plain English
A critical-severity security flaw in Apache InLong from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 67% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Insufficient Session Expiration vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.6.0. An old session can be used by an attacker even after the user has been deleted or the password has been changed. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7836 https://github.com/apache/inlong/pull/7836 , https://github.com/apache/inlong/pull/7884 https://github.com/apache/inlong/pull/7884 to solve it.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.inlong:manager-dao | 1.7.0 | GHSA-757p-7hp5-pqmr |
| Maven | org.apache.inlong:manager-pojo | 1.7.0 | GHSA-757p-7hp5-pqmr |
| Maven | org.apache.inlong:manager-service | 1.7.0 | GHSA-757p-7hp5-pqmr |
| Maven | org.apache.inlong:manager-web | 1.7.0 | GHSA-757p-7hp5-pqmr |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache InLong | 1.4.0 – through 1.6.0 |
Weakness: CWE-613 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
References
- https://lists.apache.org/thread/to7o0n2cks0omtwo6mhh5cs2vfdbplqf vendor-advisory