Vulnerability · Published May 22, 2023 · Assigned by apache
CVE-2023-31062Apache InLong: Privilege escalation vulnerability for InLong
Critical 9.8
In plain English
A critical-severity privilege mismanagement in Apache InLong from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 70% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Improper Privilege Management Vulnerabilities in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.2.0 through 1.6.0. When the attacker has access to a valid (but unprivileged) account, the exploit can be executed using Burp Suite by sending a login request and following it with a subsequent HTTP request using the returned cookie. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7836 https://github.com/apache/inlong/pull/7836 to solve it.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.inlong:manager-dao | 1.7.0 | GHSA-q5p5-xg93-2jqc |
| Maven | org.apache.inlong:manager-pojo | 1.7.0 | GHSA-q5p5-xg93-2jqc |
| Maven | org.apache.inlong:manager-service | 1.7.0 | GHSA-q5p5-xg93-2jqc |
| Maven | org.apache.inlong:manager-web | 1.7.0 | GHSA-q5p5-xg93-2jqc |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache InLong | 1.2.0 – through 1.6.0 |
Weakness: CWE-269 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
References
- https://lists.apache.org/thread/btorjbo9o71h22tcvxzy076022hjdzq0 vendor-advisory