Vulnerability · Published May 2, 2023 · Assigned by GitHub_M

CVE-2023-30861Flask vulnerable to possible disclosure of permanent session cookie due to missing Vary: Cookie header

High 7.5

In plain English

A high-severity security flaw in flask from pallets. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 70% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)1.2%top 30.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Flask is a lightweight WSGI web application framework. When all of the following conditions are met, a response containing data intended for one client may be cached and subsequently sent by the proxy to other clients. If the proxy also caches `Set-Cookie` headers, it may send one client's `session` cookie to other clients. The severity depends on the application's use of the session and the proxy's behavior regarding cookies. The risk depends on all these conditions being met. 1. The application must be hosted behind a caching proxy that does not strip cookies or ignore responses with cookies. 2. The application sets `session.permanent = True` 3. The application does not access or modify the session at any point during a request. 4. `SESSION_REFRESH_EACH_REQUEST` enabled (the default). 5. The application does not set a `Cache-Control` header to indicate that a page is private or should not be cached. This happens because vulnerable versions of Flask only set the `Vary: Cookie` header when the session is accessed or modified, not when it is refreshed (re-sent to update the expiration) without being accessed or modified. This issue has been fixed in versions 2.3.2 and 2.2.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12flask2.2.2-3DEBIAN-CVE-2023-30861
Debian:13flask2.2.2-3DEBIAN-CVE-2023-30861
Debian:14flask2.2.2-3DEBIAN-CVE-2023-30861
PyPIflask2.3.2GHSA-m2qf-hxjv-5gpq
PyPIflask2.2.5GHSA-m2qf-hxjv-5gpq
PyPIflask2.2.5, 2.3.2PYSEC-2023-62
Ubuntu:22.04:LTSflask2.0.1-2ubuntu1.1UBUNTU-CVE-2023-30861
Ubuntu:22.04:LTSflask2.0.1-2ubuntu1.1USN-6111-1

Affected products (as reported)

VendorProductVersions
pallets flask >= 2.3.0, < 2.3.2< 2.2.5

Weakness: CWE-539 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References