Vulnerability · Published May 25, 2023 · Assigned by GitHub_M

CVE-2023-30851Potential HTTP policy bypass when using header rules in Cilium

Low 2.6

In plain English

A low-severity security flaw in cilium from cilium. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)2.6Low
Exploit odds (30 days)0.7%top 48.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. This issue only impacts users who have a HTTP policy that applies to multiple `toEndpoints` AND have an allow-all rule in place that affects only one of those endpoints. In such cases, a wildcard rule will be appended to the set of HTTP rules, which could cause bypass of HTTP policies. This issue has been patched in Cilium 1.11.16, 1.12.9, and 1.13.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/cilium/cilium1.11.16GHSA-2h44-x2wx-49f4
Gogithub.com/cilium/cilium1.12.9GHSA-2h44-x2wx-49f4
Gogithub.com/cilium/cilium1.13.2GHSA-2h44-x2wx-49f4
Gogithub.com/cilium/cilium1.11.16, 1.12.9, 1.13.2GO-2023-1785

Affected products (as reported)

VendorProductVersions
cilium cilium < 1.11.16>= 1.12.0, < 1.12.9>= 1.13.0, < 1.13.2

Weakness: CWE-693 · Vector: CVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:C/C:L/I:N/A:N

References