Vulnerability · Published Apr 27, 2023 · Assigned by GitHub_M
CVE-2023-30850Pimcore SQL Injection Vulnerability in Admin Translations API
High 8.8
In plain English
A high-severity SQL injection in pimcore from pimcore. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.8%top 43.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Pimcore is an open source data and experience management platform. Prior to version 10.5.21, a SQL Injection vulnerability exists in the admin translations API. Users should update to version 10.5.21 to receive a patch or, as a workaround, or apply the patch manually.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | pimcore/pimcore | 10.5.21 | GHSA-jwg4-qcgv-5wg6 |
Affected products (as reported)
Weakness: CWE-89 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/pimcore/pimcore/security/advisories/GHSA-jwg4-qcgv-5wg6 x_refsource_CONFIRM
- https://github.com/pimcore/pimcore/pull/14952 x_refsource_MISC
- https://github.com/pimcore/pimcore/commit/7e32cc28145274ddfc30fb791012d26c1278bd38.patch x_refsource_MISC