Vulnerability · Published Apr 24, 2023 · Assigned by GitHub_M
CVE-2023-30627jellyfin-web has a stored cross-site scripting vulnerability in devices.js
Critical 9.1
In plain English
A critical-severity cross-site scripting in jellyfin-web from jellyfin. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 70% of all known vulnerabilities).
Official description
jellyfin-web is the web client for Jellyfin, a free-software media system. Starting in version 10.1.0 and prior to version 10.8.10, a stored cross-site scripting vulnerability in device.js can be used to make arbitrary calls to the `REST` endpoints with admin privileges. When combined with CVE-2023-30626, this results in remote code execution on the Jellyfin instance in the context of the user who's running it. This issue is patched in version 10.8.10. There are no known workarounds.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| jellyfin | jellyfin-web | >= 10.1.0, < 10.8.10 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
References
- https://github.com/jellyfin/jellyfin-web/security/advisories/GHSA-89hp-h43h-r5pq x_refsource_CONFIRM
- https://github.com/jellyfin/jellyfin/security/advisories/GHSA-9p5f-5x8v-x65m x_refsource_MISC
- https://github.com/jellyfin/jellyfin-web/commit/b88a5951e1a517ff4c820e693d9c0da981cf68ee x_refsource_MISC
- https://github.com/jellyfin/jellyfin-web/releases/tag/v10.8.10 x_refsource_MISC