Vulnerability · Published Aug 14, 2023 · Assigned by apple
CVE-2023-28198
High 8.8
In plain English
A high-severity security flaw in iOS and iPadOS from Apple. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 61% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS NVD)8.8High
Exploit odds (30 days)0.9%top 39.4% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
A use-after-free issue was addressed with improved memory management. This issue is fixed in iOS 16.4 and iPadOS 16.4, macOS Ventura 13.3. Processing web content may lead to arbitrary code execution.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | webkit2gtk3 | 2.40.5-1.el8 | ALSA-2023:7055 |
| AlmaLinux:9 | webkit2gtk3 | 2.40.5-1.el9 | ALSA-2023:6535 |
| AlmaLinux:8 | webkit2gtk3-devel | 2.40.5-1.el8 | ALSA-2023:7055 |
| AlmaLinux:9 | webkit2gtk3-devel | 2.40.5-1.el9 | ALSA-2023:6535 |
| AlmaLinux:8 | webkit2gtk3-jsc | 2.40.5-1.el8 | ALSA-2023:7055 |
| AlmaLinux:9 | webkit2gtk3-jsc | 2.40.5-1.el9 | ALSA-2023:6535 |
| AlmaLinux:8 | webkit2gtk3-jsc-devel | 2.40.5-1.el8 | ALSA-2023:7055 |
| AlmaLinux:9 | webkit2gtk3-jsc-devel | 2.40.5-1.el9 | ALSA-2023:6535 |
| Debian:12 | webkit2gtk | 2.40.1-1 | DEBIAN-CVE-2023-28198 |
| Debian:13 | webkit2gtk | 2.40.1-1 | DEBIAN-CVE-2023-28198 |
| Debian:14 | webkit2gtk | 2.40.1-1 | DEBIAN-CVE-2023-28198 |
| Debian:12 | wpewebkit | no fix listed | DEBIAN-CVE-2023-28198 |
| Debian:13 | wpewebkit | 2.40.2-2 | DEBIAN-CVE-2023-28198 |
| Debian:14 | wpewebkit | 2.40.2-2 | DEBIAN-CVE-2023-28198 |
| Ubuntu:22.04:LTS | qtwebkit-opensource-src | no fix listed | UBUNTU-CVE-2023-28198 |
| Ubuntu:24.04:LTS | qtwebkit-opensource-src | no fix listed | UBUNTU-CVE-2023-28198 |
| Ubuntu:22.04:LTS | webkit2gtk | 2.40.4-0ubuntu0.22.04.1 | UBUNTU-CVE-2023-28198 |
| Ubuntu:22.04:LTS | wpewebkit | no fix listed | UBUNTU-CVE-2023-28198 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apple | macOS | unspecified – before 13.3 |
| Apple | iOS and iPadOS | unspecified – before 16.4 |