Vulnerability · Published Mar 6, 2023 · Assigned by mitre
CVE-2023-27891
High 7.5
In plain English
A high-severity security flaw in the pretix package (PyPI). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS NVD)7.5High
Exploit odds (30 days)0.6%top 49.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
rami.io pretix before 4.17.1 allows OAuth application authorization from a logged-out session. The fixed versions are 4.15.1, 4.16.1, and 4.17.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | pretix | 4.17.1 | GHSA-r76w-3wwq-jv6v |
| PyPI | pretix | 4.16.1 | GHSA-r76w-3wwq-jv6v |
| PyPI | pretix | 4.15.1 | GHSA-r76w-3wwq-jv6v |
| PyPI | pretix | 4.17.1 | PYSEC-2023-42 |