Vulnerability · Published Mar 13, 2023 · Assigned by GitHub_M

CVE-2023-27580CodeIgniter Shield Password Shucking Vulnerability

High 7.5

In plain English

A high-severity security flaw in shield from codeigniter4. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.5%top 55.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

CodeIgniter Shield provides authentication and authorization for the CodeIgniter 4 PHP framework. An improper implementation was found in the password storage process. All hashed passwords stored in Shield v1.0.0-beta.3 or earlier are easier to crack than expected due to the vulnerability. Therefore, they should be removed as soon as possible. If an attacker gets (1) the user's hashed password by Shield, and (2) the hashed password (SHA-384 hash without salt) from somewhere, the attacker may easily crack the user's password. Upgrade to Shield v1.0.0-beta.4 or later to fix this issue. After upgrading, all users’ hashed passwords should be updated (saved to the database). There are no known workarounds.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcodeigniter4/shield1.0.0-beta.4GHSA-c5vj-f36q-p9vg

Affected products (as reported)

VendorProductVersions
codeigniter4 shield < 1.0.0-beta.4

Weakness: CWE-916 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References