Vulnerability · Published Apr 4, 2023 · Assigned by GitHub_M
CVE-2023-27491Envoy forwards invalid Http2/Http3 downstream headers
Medium 5.4
In plain English
A medium-severity improper input validation in envoy from envoyproxy. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities).
Official description
Envoy is an open source edge and service proxy designed for cloud-native applications. Compliant HTTP/1 service should reject malformed request lines. Prior to versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9, There is a possibility that non compliant HTTP/1 service may allow malformed requests, potentially leading to a bypass of security policies. This issue is fixed in versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| envoyproxy | envoy | >= 1.25.0, < 1.25.3>= 1.24.0, < 1.24.4>= 1.23.0, < 1.23.6< 1.22.9 |
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
References
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-5jmv-cw9p-f9rp x_refsource_CONFIRM
- https://datatracker.ietf.org/doc/html/rfc9113#section-8.3 x_refsource_MISC
- https://datatracker.ietf.org/doc/html/rfc9114#section-4.3.1 x_refsource_MISC
- https://www.rfc-editor.org/rfc/rfc9110#section-5.6.2 x_refsource_MISC