Vulnerability · Published Mar 8, 2023 · Assigned by GitHub_M
CVE-2023-27486Insufficient authorization validation between zones when xCAT zones are enabled
High 8.1
In plain English
A high-severity incorrect authorization in xcat-core from xcat2. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 58% of all known vulnerabilities).
Official description
xCAT is a toolkit for deployment and administration of computer clusters. In versions prior to 2.16.5 if zones are configured as a mechanism to secure clusters in XCAT, it is possible for a local root user from one node to obtain credentials to SSH to any node in any zone, except the management node of the default zone. XCAT zones are not enabled by default. Only users that use the optional zone feature are impacted. All versions of xCAT prior to xCAT 2.16.5 are vulnerable. This problem has been fixed in xCAT 2.16.5. Users making use of zones should upgrade to 2.16.5. Users unable to upgrade may mitigate the issue by disabling zones or patching the management node with the fix contained in commit `85149c37f49`.
Affected products (as reported)
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
References
- https://github.com/xcat2/xcat-core/security/advisories/GHSA-hpxg-7428-6jvv x_refsource_CONFIRM
- https://github.com/xcat2/xcat-core/issues/7246 x_refsource_MISC
- https://github.com/xcat2/xcat-core/pull/7247 x_refsource_MISC
- https://github.com/xcat2/xcat-core/pull/7247/commits/85149c37f49dbca7bd85f1f586960315604fc024 x_refsource_MISC