Vulnerability · Published Feb 25, 2023 · Assigned by GitHub_M
CVE-2023-26039ZoneMinder vulnerable to OS Command injection in daemonControl() API
High 7.1
In plain English
A high-severity OS command injection in zoneminder from ZoneMinder. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 70% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
ZoneMinder is a free, open source Closed-circuit television software application for Linux which supports IP, USB and Analog cameras. Versions prior to 1.36.33 and 1.37.33 contain an OS Command Injection via daemonControl() in (/web/api/app/Controller/HostController.php). Any authenticated user can construct an api command to execute any shell command as the web user. This issue is patched in versions 1.36.33 and 1.37.33.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | zoneminder | 1.36.33+dfsg1-1 | DEBIAN-CVE-2023-26039 |
| Debian:13 | zoneminder | 1.36.33+dfsg1-1 | DEBIAN-CVE-2023-26039 |
| Debian:14 | zoneminder | 1.36.33+dfsg1-1 | DEBIAN-CVE-2023-26039 |
| Ubuntu:24.04:LTS | zoneminder | no fix listed | UBUNTU-CVE-2023-26039 |
| Ubuntu:25.10 | zoneminder | no fix listed | UBUNTU-CVE-2023-26039 |
| Ubuntu:26.04:LTS | zoneminder | no fix listed | UBUNTU-CVE-2023-26039 |
| Ubuntu:26.10 | zoneminder | no fix listed | UBUNTU-CVE-2023-26039 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| ZoneMinder | zoneminder | < 1.36.33>= 1.37.0, < 1.37.33 |
Weakness: CWE-78 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
References
- https://github.com/ZoneMinder/zoneminder/security/advisories/GHSA-44q8-h2pw-cc9g x_refsource_CONFIRM