Vulnerability · Published Feb 25, 2023 · Assigned by GitHub_M

CVE-2023-25825ZoneMinder contains Cross-site Scripting via log viewing

High 7.7

In plain English

A high-severity cross-site scripting in zoneminder from ZoneMinder. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.7High
Exploit odds (30 days)0.7%top 46.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

ZoneMinder is a free, open source Closed-circuit television software application for Linux which supports IP, USB and Analog cameras. Versions prior to 1.36.33 are vulnerable to Cross-site Scripting. Log entries can be injected into the database logs, containing a malicious referrer field. This is unescaped when viewing the logs in the web ui. This issue is patched in version 1.36.33.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12zoneminder1.36.33+dfsg1-1DEBIAN-CVE-2023-25825
Debian:13zoneminder1.36.33+dfsg1-1DEBIAN-CVE-2023-25825
Debian:14zoneminder1.36.33+dfsg1-1DEBIAN-CVE-2023-25825
Ubuntu:24.04:LTSzoneminderno fix listedUBUNTU-CVE-2023-25825
Ubuntu:25.10zoneminderno fix listedUBUNTU-CVE-2023-25825
Ubuntu:26.04:LTSzoneminderno fix listedUBUNTU-CVE-2023-25825
Ubuntu:26.10zoneminderno fix listedUBUNTU-CVE-2023-25825

Affected products (as reported)

VendorProductVersions
ZoneMinder zoneminder < 1.36.33

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

References