Vulnerability · Published Mar 27, 2023 · Assigned by GitHub_M
CVE-2023-25661Denial of Service in TensorFlow
Medium 6.5
In plain English
A medium-severity improper input validation in tensorflow from tensorflow. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
TensorFlow is an Open Source Machine Learning Framework. In versions prior to 2.11.1 a malicious invalid input crashes a tensorflow model (Check Failed) and can be used to trigger a denial of service attack. A proof of concept can be constructed with the `Convolution3DTranspose` function. This Convolution3DTranspose layer is a very common API in modern neural networks. The ML models containing such vulnerable components could be deployed in ML applications or as cloud services. This failure could be potentially used to trigger a denial of service attack on ML cloud services. An attacker must have privilege to provide input to a `Convolution3DTranspose` call. This issue has been patched and users are advised to upgrade to version 2.11.1. There are no known workarounds for this vulnerability.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | tensorflow | 2.11.1 | GHSA-fxgc-95xx-grvq |
| PyPI | tensorflow | 2.11.1 | PYSEC-2026-3182 |
| PyPI | tensorflow-cpu | 2.11.1 | GHSA-fxgc-95xx-grvq |
| PyPI | tensorflow-cpu | 2.11.1 | PYSEC-2026-1952 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| tensorflow | tensorflow | < 2.11.1 |
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H