Vulnerability · Published Feb 23, 2023 · Assigned by apache

CVE-2023-25621Apache Sling does not allow to handle i18n content in a secure way

Medium 6.5

In plain English

A medium-severity security flaw in Apache Sling from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 67% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)1.1%top 33.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Privilege Escalation vulnerability in Apache Software Foundation Apache Sling. Any content author is able to create i18n dictionaries in the repository in a location the author has write access to. As these translations are used across the whole product, it allows an author to change any text or dialog in the product. For example an attacker might fool someone by changing the text on a delete button to "Info". This issue affects the i18n module of Apache Sling up to version 2.5.18. Version 2.6.2 and higher limit by default i18m dictionaries to certain paths in the repository (/libs and /apps). Users of the module are advised to update to version 2.6.2 or higher, check the configuration for resource loading and then adjust the access permissions for the configured path accordingly.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.sling:org.apache.sling.i18n2.6.2GHSA-mrpv-5pmr-p92h

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Sling Apache Sling i18n – through 2.5.18

References