Vulnerability · Published Apr 20, 2023 · Assigned by apache
CVE-2023-25601Apache DolphinScheduler 3.0.0 to 3.1.1 python gateway has improper authentication
Medium 4.3
In plain English
A medium-severity improper authentication in Apache DolphinScheduler from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 66% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
On version 3.0.0 through 3.1.1, Apache DolphinScheduler's python gateway suffered from improper authentication: an attacker could use a socket bytes attack without authentication. This issue has been fixed from version 3.1.2 onwards. For users who use version 3.0.0 to 3.1.1, you can turn off the python-gateway function by changing the value `python-gateway.enabled=false` in configuration file `application.yaml`. If you are using the python gateway, please upgrade to version 3.1.2 or above.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.dolphinscheduler:dolphinscheduler-api | 3.1.2 | GHSA-3jxw-cv35-2mmv |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache DolphinScheduler | 3.0.0 – before 3.1.2 |
Weakness: CWE-287