Vulnerability · Published Feb 14, 2023 · Assigned by GitHub_M

CVE-2023-25566GSS-NTLMSSP vulnerable to memory leak when parsing usernames

High 7.5

In plain English

A high-severity memory leak in gss-ntlmssp from gssapi. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 66% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)1.1%top 34.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, a memory leak can be triggered when parsing usernames which can trigger a denial-of-service. The domain portion of a username may be overridden causing an allocated memory area the size of the domain name to be leaked. An attacker can leak memory via the main `gss_accept_sec_context` entry point, potentially causing a denial-of-service. This issue is fixed in version 1.2.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8gssntlmssp1.2.0-1.el8_8ALSA-2023:3097
Debian:12gss-ntlmssp1.2.0-1DEBIAN-CVE-2023-25566
Debian:13gss-ntlmssp1.2.0-1DEBIAN-CVE-2023-25566
Debian:14gss-ntlmssp1.2.0-1DEBIAN-CVE-2023-25566
Ubuntu:24.04:LTSgss-ntlmssp1.2.0-1build3UBUNTU-CVE-2023-25566

Affected products (as reported)

VendorProductVersions
gssapi gss-ntlmssp < 1.2.0

Weakness: CWE-401 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References