Vulnerability · Published Feb 14, 2023 · Assigned by GitHub_M
CVE-2023-25565GSS-NTLMSSP vulnerable to incorrect free when decoding target information
High 7.5
In plain English
A high-severity security flaw in gss-ntlmssp from gssapi. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 66% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, an incorrect free when decoding target information can trigger a denial of service. The error condition incorrectly assumes the `cb` and `sh` buffers contain a copy of the data that needs to be freed. However, that is not the case. This vulnerability can be triggered via the main `gss_accept_sec_context` entry point. This will likely trigger an assertion failure in `free`, causing a denial-of-service. This issue is fixed in version 1.2.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | gssntlmssp | 1.2.0-1.el8_8 | ALSA-2023:3097 |
| Debian:12 | gss-ntlmssp | 1.2.0-1 | DEBIAN-CVE-2023-25565 |
| Debian:13 | gss-ntlmssp | 1.2.0-1 | DEBIAN-CVE-2023-25565 |
| Debian:14 | gss-ntlmssp | 1.2.0-1 | DEBIAN-CVE-2023-25565 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| gssapi | gss-ntlmssp | < 1.2.0 |
Weakness: CWE-590 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H