Vulnerability · Published Feb 14, 2023 · Assigned by GitHub_M

CVE-2023-25564GSS-NTLMSSP vulnerable to memory corruption when decoding UTF16 strings

Medium 6.5

In plain English

A medium-severity out-of-bounds write in gss-ntlmssp from gssapi. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.9% (higher than 80% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)1.9%top 19.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, memory corruption can be triggered when decoding UTF16 strings. The variable `outlen` was not initialized and could cause writing a zero to an arbitrary place in memory if `ntlm_str_convert()` were to fail, which would leave `outlen` uninitialized. This can lead to a denial of service if the write hits unmapped memory or randomly corrupts a byte in the application memory space. This vulnerability can trigger an out-of-bounds write, leading to memory corruption. This vulnerability can be triggered via the main `gss_accept_sec_context` entry point. This issue is fixed in version 1.2.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8gssntlmssp1.2.0-1.el8_8ALSA-2023:3097
Debian:12gss-ntlmssp1.2.0-1DEBIAN-CVE-2023-25564
Debian:13gss-ntlmssp1.2.0-1DEBIAN-CVE-2023-25564
Debian:14gss-ntlmssp1.2.0-1DEBIAN-CVE-2023-25564

Affected products (as reported)

VendorProductVersions
gssapi gss-ntlmssp < 1.2.0

Weakness: CWE-787 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H

References