Vulnerability · Published Feb 8, 2023 · Assigned by GitHub_M
CVE-2023-25168Symbolic Link (Symlink) Following allowing the deletion of files and directories on the host system in wings
Critical 9.6
In plain English
A critical-severity security flaw in wings from pterodactyl. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 62% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Wings is Pterodactyl's server control plane. This vulnerability can be used to delete files and directories recursively on the host system. This vulnerability can be combined with `GHSA-p8r3-83r8-jwj5` to overwrite files on the host system. In order to use this exploit, an attacker must have an existing "server" allocated and controlled by Wings. This vulnerability has been resolved in version `v1.11.4` of Wings, and has been back-ported to the 1.7 release series in `v1.7.4`. Anyone running `v1.11.x` should upgrade to `v1.11.4` and anyone running `v1.7.x` should upgrade to `v1.7.4`. There are no known workarounds for this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/pterodactyl/wings | 1.7.4 | GHSA-66p8-j459-rq63 |
| Go | github.com/pterodactyl/wings | 1.11.4 | GHSA-66p8-j459-rq63 |
| Go | github.com/pterodactyl/wings | 1.11.4, 1.7.4 | GO-2023-1555 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| pterodactyl | wings | < 1.7.4>= 1.11.0, < 1.11.4 |
Weakness: CWE-59 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:H