Vulnerability · Published Feb 16, 2023 · Assigned by GitHub_M
CVE-2023-25153containerd OCI image importer memory exhaustion
Medium 6.2
In plain English
A medium-severity resource allocation without limits in containerd from containerd. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 30% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
containerd is an open source container runtime. Before versions 1.6.18 and 1.5.18, when importing an OCI image, there was no limit on the number of bytes read for certain files. A maliciously crafted image with a large file where a limit was not applied could cause a denial of service. This bug has been fixed in containerd 1.6.18 and 1.5.18. Users should update to these versions to resolve the issue. As a workaround, ensure that only trusted images are used and that only trusted users have permissions to import images.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.20 | containerd | 1.6.18-r0 | ALPINE-CVE-2023-25153 |
| Alpine:v3.21 | containerd | 1.6.18-r0 | ALPINE-CVE-2023-25153 |
| Alpine:v3.22 | containerd | 1.6.18-r0 | ALPINE-CVE-2023-25153 |
| Alpine:v3.23 | containerd | 1.6.18-r0 | ALPINE-CVE-2023-25153 |
| Alpine:v3.24 | containerd | 1.6.18-r0 | ALPINE-CVE-2023-25153 |
| Debian:12 | containerd | 1.6.18~ds1-1 | DEBIAN-CVE-2023-25153 |
| Debian:13 | containerd | 1.6.18~ds1-1 | DEBIAN-CVE-2023-25153 |
| Debian:14 | containerd | 1.6.18~ds1-1 | DEBIAN-CVE-2023-25153 |
| Go | github.com/containerd/containerd | 1.6.18 | GHSA-259w-8hf6-59c2 |
| Go | github.com/containerd/containerd | 1.5.18, 1.6.18 | GO-2023-1573 |
| Go | github.com/containerd/containerd | 1.5.18 | GHSA-259w-8hf6-59c2 |
| Ubuntu:22.04:LTS | containerd | 1.6.12-0ubuntu1~22.04.3 | UBUNTU-CVE-2023-25153 |
| Ubuntu:22.04:LTS | containerd | 1.6.12-0ubuntu1~22.04.3 | USN-6202-1 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| containerd | containerd | < 1.5.18>= 1.6.0, < 1.6.18 |
Weakness: CWE-770 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/containerd/containerd/security/advisories/GHSA-259w-8hf6-59c2 x_refsource_CONFIRM
- https://github.com/containerd/containerd/commit/0c314901076a74a7b797a545d2f462285fdbb8c4 x_refsource_MISC
- https://github.com/containerd/containerd/releases/tag/v1.5.18 x_refsource_MISC
- https://github.com/containerd/containerd/releases/tag/v1.6.18 x_refsource_MISC