Vulnerability · Published Feb 22, 2023 · Assigned by GitHub_M
CVE-2023-24810Cross site scripting (XSS) vulnerability using authentication callback in Misskey
High 7.1
In plain English
A high-severity cross-site scripting in misskey from misskey-dev. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities).
Official description
Misskey is an open source, decentralized social media platform. Due to insufficient validation of the redirect URL during `miauth` authentication in Misskey, arbitrary JavaScript can be executed when a user allows the link. All versions below 13.3.1 (including 12.x) are affected. This has been fixed in version 13.3.1. Users are advised to upgrade. Users unable to upgrade should not allow authentication of untrusted apps.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| misskey-dev | misskey | < 13.3.1 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
References
- https://github.com/misskey-dev/misskey/security/advisories/GHSA-cc6r-chgr-8r5m x_refsource_CONFIRM