Vulnerability · Published Feb 23, 2023 · Assigned by hackerone
CVE-2023-23914
Critical 9.1
In plain English
A critical-severity security flaw in https://github.com/curl/curl. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
A cleartext transmission of sensitive information vulnerability exists in curl <v7.88.0 that could cause HSTS functionality fail when multiple URLs are requested serially. Using its HSTS support, curl can be instructed to use HTTPS instead of usingan insecure clear-text HTTP step even when HTTP is provided in the URL. ThisHSTS mechanism would however surprisingly be ignored by subsequent transferswhen done on the same command line because the state would not be properlycarried on.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.20 | curl | 7.88.0-r0 | ALPINE-CVE-2023-23914 |
| Alpine:v3.21 | curl | 7.88.0-r0 | ALPINE-CVE-2023-23914 |
| Alpine:v3.22 | curl | 7.88.0-r0 | ALPINE-CVE-2023-23914 |
| Alpine:v3.23 | curl | 7.88.0-r0 | ALPINE-CVE-2023-23914 |
| Alpine:v3.24 | curl | 7.88.0-r0 | ALPINE-CVE-2023-23914 |
| Debian:12 | curl | 7.88.1-1 | DEBIAN-CVE-2023-23914 |
| Debian:13 | curl | 7.88.1-1 | DEBIAN-CVE-2023-23914 |
| Debian:14 | curl | 7.88.1-1 | DEBIAN-CVE-2023-23914 |
| Ubuntu:22.04:LTS | curl | 7.81.0-1ubuntu1.8 | UBUNTU-CVE-2023-23914 |
| Ubuntu:22.04:LTS | curl | 7.81.0-1ubuntu1.8 | USN-5891-1 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| n/a | https://github.com/curl/curl | Fixed in 7.88.0 |
Weakness: CWE-319 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N