Vulnerability · Published Jan 27, 2023 · Assigned by GitHub_M
CVE-2023-23621Discourse vulnerable to ReDoS in user agent parsing
High 8.6
In plain English
A high-severity regular-expression denial of service in discourse from discourse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities).
Official description
Discourse is an open-source discussion platform. Prior to version 3.0.1 on the `stable` branch and version 3.1.0.beta2 on the `beta` and `tests-passed` branches, a malicious user can cause a regular expression denial of service using a carefully crafted user agent. This issue is patched in version 3.0.1 on the `stable` branch and version 3.1.0.beta2 on the `beta` and `tests-passed` branches. There are no known workarounds.
Affected products (as reported)
Weakness: CWE-1333 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
References
- https://github.com/discourse/discourse/security/advisories/GHSA-mrfp-54hf-jrcv x_refsource_CONFIRM
- https://github.com/discourse/discourse/pull/20002 x_refsource_MISC
- https://github.com/discourse/discourse/commit/6d92c3cbdac431db99a450f360a3048bb3aaf458 x_refsource_MISC