Vulnerability · Published Jan 24, 2023 · Assigned by GitHub_M
CVE-2023-23613Field-level security issue with .keyword fields in OpenSearch
Medium 5.7
In plain English
A medium-severity information exposure in security from opensearch-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
OpenSearch is an open source distributed and RESTful search engine. In affected versions there is an issue in the implementation of field-level security (FLS) and field masking where rules written to explicitly exclude fields are not correctly applied for certain queries that rely on their auto-generated .keyword fields. This issue is only present for authenticated users with read access to the indexes containing the restricted fields. This may expose data which may otherwise not be accessible to the user. OpenSearch 1.0.0-1.3.7 and 2.0.0-2.4.1 are affected. Users are advised to upgrade to OpenSearch 1.3.8 or 2.5.0. Users unable to upgrade may write explicit exclusion rules as a workaround. Policies authored in this way are not subject to this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.opensearch.plugin:opensearch-security | 1.3.8 | GHSA-v3cg-7r9h-r2g6 |
| Maven | org.opensearch.plugin:opensearch-security | 2.5.0 | GHSA-v3cg-7r9h-r2g6 |
| Ubuntu:24.04:LTS | opensearch | no fix listed | UBUNTU-CVE-2023-23613 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| opensearch-project | security | >= 2.0.0, < 2.5.0< 1.3.8 |
Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N