Vulnerability · Published Nov 15, 2024 · Assigned by @huntr_ai
CVE-2023-2332Stored Cross-site Scripting (XSS) in pimcore/pimcore
Medium 4.0
In plain English
A medium-severity cross-site scripting in pimcore/pimcore from pimcore. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
A stored Cross-site Scripting (XSS) vulnerability exists in the Conditions tab of Pricing Rules in pimcore/pimcore versions 10.5.19. The vulnerability is present in the From and To fields of the Date Range section, allowing an attacker to inject malicious scripts. This can lead to the execution of arbitrary JavaScript code in the context of the user's browser, potentially stealing cookies or redirecting users to malicious sites. The issue is fixed in version 10.5.21.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | pimcore/pimcore | 10.5.21 | GHSA-r7mm-jx6h-hv7m |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| pimcore | pimcore/pimcore | unspecified – before 10.5.21 |
Weakness: CWE-79 · Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L