Vulnerability · Published Apr 17, 2023 · Assigned by apache
CVE-2023-22946Apache Spark proxy-user privilege escalation from malicious configuration class
Medium 6.4
In plain English
A medium-severity privilege mismanagement in Apache Spark from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 66% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
In Apache Spark versions prior to 3.4.0, applications using spark-submit can specify a 'proxy-user' to run as, limiting privileges. The application can execute code with the privileges of the submitting user, however, by providing malicious configuration-related classes on the classpath. This affects architectures relying on proxy-user, for example those using Apache Livy to manage submitted applications. Update to Apache Spark 3.4.0 or later, and ensure that spark.submit.proxyUser.allowCustomClasspathInClusterMode is set to its default of "false", and is not overridden by submitted applications.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.spark:spark-core_2.12 | 3.3.3 | GHSA-329j-jfvr-rhr6 |
| Maven | org.apache.spark:spark-core_2.13 | 3.3.3 | GHSA-329j-jfvr-rhr6 |
| PyPI | pyspark | 3.3.2 | GHSA-329j-jfvr-rhr6 |
| PyPI | pyspark | 3.4.0 | PYSEC-2023-44 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Spark | 0 – before 3.4.0 |
Weakness: CWE-269 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
References
- https://lists.apache.org/thread/yllfl25xh5tbotjmg93zrq4bzwhqc0gv vendor-advisory