Vulnerability · Published Jan 17, 2023 · Assigned by GitHub_M

CVE-2023-22731Improper Control of Generation of Code in Twig rendered views in shopware

Critical 10.0

In plain English

A critical-severity code injection in platform from shopware. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 72% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)10.0Critical
Exploit odds (30 days)1.4%top 27.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Shopware is an open source commerce platform based on Symfony Framework and Vue js. In a Twig environment **without the Sandbox extension**, it is possible to refer to PHP functions in twig filters like `map`, `filter`, `sort`. This allows a template to call any global PHP function and thus execute arbitrary code. The attacker must have access to a Twig environment in order to exploit this vulnerability. This problem has been fixed with 6.4.18.1 with an override of the specified filters until the integration of the Sandbox extension has been finished. Users are advised to upgrade. Users of major versions 6.1, 6.2, and 6.3 may also receive this fix via a plugin.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistshopware/core6.4.18.1GHSA-93cw-f5jj-x85w
Packagistshopware/platform6.4.18.1GHSA-93cw-f5jj-x85w

Affected products (as reported)

VendorProductVersions
shopware platform < 6.4.18.1

Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

References