Vulnerability · Published Jan 14, 2023 · Assigned by GitHub_M
CVE-2023-22478KubePi is vulnerable to missing authorization
High 7.3
In plain English
A high-severity missing authorization in KubePi from KubeOperator. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.7% (higher than 90% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei. Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)7.3High
Exploit odds (30 days)3.7%top 10.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Nuclei
Official description
KubePi is a modern Kubernetes panel. The API interfaces with unauthorized entities and may leak sensitive information. This issue has been patched in version 1.6.4. There are currently no known workarounds.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/KubeOperator/kubepi | 1.6.4 | GHSA-gqx8-hxmv-c4v4 |
| Go | github.com/KubeOperator/kubepi | 1.6.4 | GO-2023-1463 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| KubeOperator | KubePi | <= 1.6.3 |
Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L