Vulnerability · Published Jan 4, 2023 · Assigned by GitHub_M

CVE-2023-22457org.xwiki.contrib:application-ckeditor-ui vulnerable to Remote Code Execution via Cross-Site Request Forgery

Critical 9.1

In plain English

A critical-severity cross-site request forgery in application-ckeditor from xwiki-contrib. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 19.3% (higher than 97% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)19.3%top 2.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

CKEditor Integration UI adds support for editing wiki pages using CKEditor. Prior to versions 1.64.3,t he `CKEditor.HTMLConverter` document lacked a protection against Cross-Site Request Forgery (CSRF), allowing to execute macros with the rights of the current user. If a privileged user with programming rights was tricked into executing a GET request to this document with certain parameters (e.g., via an image with a corresponding URL embedded in a comment or via a redirect), this would allow arbitrary remote code execution and the attacker could gain rights, access private information or impact the availability of the wiki. The issue has been patched in the CKEditor Integration version 1.64.3. This has also been patched in the version of the CKEditor integration that is bundled starting with XWiki 14.6 RC1. There are no known workarounds for this other than upgrading the CKEditor integration to a fixed version.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.xwiki.contrib:application-ckeditor-ui1.64.3GHSA-6mjp-2rm6-9g85
Ubuntu:22.04:LTSckeditor3no fix listedUBUNTU-CVE-2023-22457
Ubuntu:24.04:LTSckeditor3no fix listedUBUNTU-CVE-2023-22457
Ubuntu:22.04:LTSldap-account-managerno fix listedUBUNTU-CVE-2023-22457
Ubuntu:24.04:LTSldap-account-managerno fix listedUBUNTU-CVE-2023-22457
Ubuntu:25.10ldap-account-managerno fix listedUBUNTU-CVE-2023-22457
Ubuntu:26.04:LTSldap-account-managerno fix listedUBUNTU-CVE-2023-22457
Ubuntu:22.04:LTSrequest-tracker4no fix listedUBUNTU-CVE-2023-22457
Ubuntu:24.04:LTSrequest-tracker4no fix listedUBUNTU-CVE-2023-22457
Ubuntu:25.10request-tracker4no fix listedUBUNTU-CVE-2023-22457
Ubuntu:26.04:LTSrequest-tracker4no fix listedUBUNTU-CVE-2023-22457

Affected products (as reported)

VendorProductVersions
xwiki-contrib application-ckeditor < 1.64.3

Weakness: CWE-352 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

References