Vulnerability · Published Apr 20, 2023 · Assigned by vmware
CVE-2023-20873
Critical 9.8
In plain English
A critical-severity security flaw in Spring Boot. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 66% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.springframework.boot:spring-boot-actuator-autoconfigure | 3.0.6 | GHSA-g5h3-w546-pj7f |
| Maven | org.springframework.boot:spring-boot-actuator-autoconfigure | 2.7.11 | GHSA-g5h3-w546-pj7f |
| Maven | org.springframework.boot:spring-boot-actuator-autoconfigure | 2.6.15 | GHSA-g5h3-w546-pj7f |
| Maven | org.springframework.boot:spring-boot-actuator-autoconfigure | 2.5.15 | GHSA-g5h3-w546-pj7f |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| n/a | Spring Boot | Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions |