Vulnerability · Published Mar 14, 2023 · Assigned by HashiCorp
CVE-2023-1296Nomad ACLs Can Not Deny Access to Workload's Own Variables
Low 2.7
In plain English
A low-severity security flaw in Nomad from HashiCorp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)2.7Low
Exploit odds (30 days)0.5%top 54.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
HashiCorp Nomad and Nomad Enterprise 1.4.0 up to 1.5.0 did not correctly enforce deny policies applied to a workload’s variables. Fixed in 1.4.6 and 1.5.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/hashicorp/nomad | 1.4.6 | GHSA-hhvx-8755-4cvw |
| Go | github.com/hashicorp/nomad | 1.5.1 | GHSA-hhvx-8755-4cvw |
| Go | github.com/hashicorp/nomad | 1.4.6, 1.5.1 | GO-2023-1899 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| HashiCorp | Nomad | 1.5.01.4.0 – before 1.4.6 |
| HashiCorp | Nomad Enterprise | 1.5.01.4.0 – before 1.4.6 |
Weakness: CWE-682 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N