Vulnerability · Published Mar 8, 2023 · Assigned by VulDB
CVE-2023-1277kylin-system-updater Update InstallSnap command injection
High 7.8
In plain English
A high-severity command injection in kylin-system-updater. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.8% (higher than 79% of all known vulnerabilities).
Official description
A vulnerability, which was classified as critical, was found in kylin-system-updater up to 1.4.20kord on Ubuntu Kylin. Affected is the function InstallSnap of the component Update Handler. The manipulation leads to command injection. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used. The identifier of this vulnerability is VDB-222600.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| n/a | kylin-system-updater | 1.4.20kord |
Weakness: CWE-77 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://vuldb.com/?id.222600 vdb-entry, technical-description
- https://vuldb.com/?ctiid.222600 signature, permissions-required
- https://github.com/cn-lwj/vuldb/blob/master/kylin-system-updater_vuln.md broken-link, exploit, patch