Vulnerability · Published Aug 14, 2023 · Assigned by OpenNMS
CVE-2023-0872ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users
High 8.2
In plain English
A high-severity privilege mismanagement in Horizon from The OpenNMS Group. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.3% (higher than 89% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit. Fixed versions are available - upgrade the affected package.
Official description
The Horizon REST API includes a users endpoint in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter for reporting this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.opennms:opennms-webapp-rest | 32.0.2 | GHSA-w5gq-xrrp-3fxf |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| The OpenNMS Group | Horizon | 31.0.8 – before 32.0.2 |
| The OpenNMS Group | Meridian | 2020.0.0 – through 2020.1.372021.0.0 – through 2021.1.292022.0.0 – through 2022.1.182023.0.0 – through 2023.1.5 |
Weakness: CWE-269 · Vector: CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:L