Vulnerability · Published Feb 23, 2023 · Assigned by OpenNMS
CVE-2023-0869Cross-site scripting in outage/list.htm
Medium 5.8
In plain English
A medium-severity improper input validation in Horizon from The OpenNMS Group. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities).
Official description
Cross-site scripting in outage/list.htm in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Meridian 2023.1.0 or newer, or Horizon 31.0.4 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.opennms:opennms-web-api | no fix listed | GHSA-7v39-jjj6-j4j4 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| The OpenNMS Group | Meridian | 2022.1.0 – before 2023.1.0 |
| The OpenNMS Group | Horizon | 29.0.0 – before 31.0.4 |
Weakness: CWE-20, CWE-79 · Vector: CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N