Vulnerability · Published Nov 15, 2024 · Assigned by @huntr_ai
CVE-2023-0737CSRF in wallabag/wallabag
Medium 6.5
In plain English
A medium-severity cross-site request forgery in wallabag/wallabag from wallabag. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.0)6.5Medium
Exploit odds (30 days)0.3%top 74.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known
Official description
wallabag version 2.5.2 contains a Cross-Site Request Forgery (CSRF) vulnerability that allows attackers to arbitrarily delete user accounts via the /account/delete endpoint. This issue is fixed in version 2.5.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | wallabag/wallabag | 2.5.4 | GHSA-99w8-c5f6-96pp |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| wallabag | wallabag/wallabag | unspecified – before 2.5.4 |
Weakness: CWE-352 · Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N