Vulnerability · Published Feb 2, 2023 · Assigned by VulDB
CVE-2023-0650YAFNET Signature cross site scripting
Low 3.5
In plain English
A low-severity cross-site scripting in YAFNET. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities).
Official description
A vulnerability was found in YAFNET up to 3.1.11 and classified as problematic. This issue affects some unknown processing of the component Signature Handler. The manipulation leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 3.1.12 is able to address this issue. The identifier of the patch is a1442a2bacc3335461b44c250e81f8d99c60735f. It is recommended to upgrade the affected component. The identifier VDB-220037 was assigned to this vulnerability.
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
References
- https://vuldb.com/?id.220037 vdb-entry, technical-description
- https://vuldb.com/?ctiid.220037 signature, permissions-required
- https://drive.google.com/drive/folders/1iJuhjLQy3QPIgKKgWUzEEfr_q0boaR00?usp=sharing exploit
- https://github.com/YAFNET/YAFNET/security/advisories/GHSA-mg6p-jjff-7g5m related
- https://github.com/YAFNET/YAFNET/commit/a1442a2bacc3335461b44c250e81f8d99c60735f patch
- https://github.com/YAFNET/YAFNET/releases/tag/v3.1.12 patch