Vulnerability · Published Mar 1, 2023 · Assigned by GRAFANA
CVE-2023-0507
High 7.3
In plain English
A high-severity cross-site scripting in Grafana from Grafana. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 15.5% (higher than 97% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Grafana is an open-source platform for monitoring and observability. Starting with the 8.1 branch, Grafana had a stored XSS vulnerability affecting the core plugin GeoMap. The stored XSS vulnerability was possible due to map attributions weren't properly sanitized and allowed arbitrary JavaScript to be executed in the context of the currently authorized user of the Grafana instance. An attacker needs to have the Editor role in order to change a panel to include a map attribution containing JavaScript. This means that vertical privilege escalation is possible, where a user with Editor role can change to a known password for a user having Admin role if the user with Admin role executes malicious JavaScript viewing a dashboard. Users may upgrade to version 8.5.21, 9.2.13 and 9.3.8 to receive a fix.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/grafana/grafana | 8.5.21 | GHSA-hjv9-hm2f-rpcj |
| Go | github.com/grafana/grafana | 9.2.13 | GHSA-hjv9-hm2f-rpcj |
| Go | github.com/grafana/grafana | 9.3.8 | GHSA-hjv9-hm2f-rpcj |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Grafana | Grafana | 8.1.0 – before 8.5.219.0.0 – before 9.2.139.3.0 – before 9.3.8 |
| Grafana | Grafana Enterprise | 8.1.0 – before 8.5.219.0.0 – before 9.2.139.3.0 – before 9.3.8 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N