Vulnerability · Published Dec 3, 2023 · Assigned by VulDB
CVE-2022-4957librespeed speedtest stats.php cross site scripting
Low 3.5
In plain English
A low-severity cross-site scripting in speedtest from librespeed. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 47% of all known vulnerabilities).
Official description
A vulnerability was found in librespeed speedtest up to 5.2.4. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file results/stats.php. The manipulation of the argument id leads to cross site scripting. The attack can be launched remotely. Upgrading to version 5.2.5 is able to address this issue. The patch is named a85f2c086f3449dffa8fe2edb5e2ef3ee72dc0e9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-246643.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| librespeed | speedtest | 5.2.05.2.15.2.25.2.35.2.4 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
References
- https://vuldb.com/?id.246643 vdb-entry, technical-description
- https://vuldb.com/?ctiid.246643 signature, permissions-required
- https://github.com/librespeed/speedtest/commit/a85f2c086f3449dffa8fe2edb5e2ef3ee72dc0e9 patch
- https://github.com/librespeed/speedtest/releases/tag/5.2.5 patch