Vulnerability · Published Jan 5, 2023 · Assigned by VulDB
CVE-2022-4877snoyberg keter Proxy.hs cross site scripting
Low 3.5
In plain English
A low-severity cross-site scripting in keter from snoyberg. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities).
Official description
A vulnerability has been found in snoyberg keter up to 1.8.1 and classified as problematic. This vulnerability affects unknown code of the file Keter/Proxy.hs. The manipulation of the argument host leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.8.2 is able to address this issue. The name of the patch is d41f3697926b231782a3ad8050f5af1ce5cc40b7. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217444.
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
References
- https://vuldb.com/?id.217444 vdb-entry, technical-description
- https://vuldb.com/?ctiid.217444 signature, permissions-required
- https://github.com/snoyberg/keter/pull/246 issue-tracking
- https://github.com/snoyberg/keter/commit/d41f3697926b231782a3ad8050f5af1ce5cc40b7 patch
- https://github.com/snoyberg/keter/releases/tag/keter%2F1.8.2 patch