Vulnerability · Published Jul 12, 2023 · Assigned by apache
CVE-2022-46651Apache Airflow: Security vulnerability on AirFlow Connections
Medium 6.5
In plain English
A medium-severity information exposure in Apache Airflow from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Apache Airflow, versions before 2.6.3, is affected by a vulnerability that allows an unauthorized actor to gain access to sensitive information in Connection edit view. This vulnerability is considered low since it requires someone with access to Connection resources specifically updating the connection to exploit it. Users should upgrade to version 2.6.3 or later which has removed the vulnerability.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | apache-airflow | 2.6.3 | GHSA-xvw9-3mhm-xjqq |
| PyPI | apache-airflow | 2.6.3 | PYSEC-2023-103 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Airflow | 0 – before 2.6.3 |
Weakness: CWE-200